Please help me install Motionbox!

I am absolutely baffled by the absence of any sort of installation guide (or wiki as it’s usually said). This is very frustrating for newbies like me. I downloaded the tarball, extracted it but I have no idea how to run/install the thing. I looked up the website 4-5 times and there is no sign of any instruction whatsoever! So please! Tell me how to install this. I loved Motionbox when I tried it on windows the other day but on Linux I am unable to start the thing.
Problem: Unable to get stated with installtion
Package name & arch: MotionBox-1.6.0-linux32 (Yes, I want to install the 32bit package, so please include this in your instruction)
My System: KUbuntu 19.10 64 bit

Greetings @idotman,

On Linux you have to run the script from the terminal. Hopefully I can come up with something more elegant in the future but that’s how it works currently.

I’m currently focused on the development, and unfortunately, have no time for documentation.

EDIT: There seems to be an issue with access rights on the Linux archive, I’ll keep you posted.

1 Like


to solve the access right problem, you have to run these two commands in the MotionBox folder:
chmod +x ./
chmod +x ./MotionBox

@bunjee I can write a basic install&run documentation for major Linux distributions if needed.

1 Like

Okay brother, I understand you. No worries. I installed it fine through latest wine. It was just as convenient as it was on Windows.
Thank you so much for your work on this amazing software!

soot@soot-kubuntu:~/Downloads/Compressed/MotionBox-1.6.0$ chmod +x ./
soot@soot-kubuntu:~/Downloads/Compressed/MotionBox-1.6.0$ chmod +x ./MotionBox
soot@soot-kubuntu:~/Downloads/Compressed/MotionBox-1.6.0$ sudo ./
[sudo] password for soot:
Starting MotionBox…
/home/soot/Downloads/Compressed/MotionBox-1.6.0/MotionBox: error while loading shared libraries: cannot open shared object file: No such file or directory
soot@soot-kubuntu:~/Downloads/Compressed/MotionBox-1.6.0$ ./
Starting MotionBox…
/home/soot/Downloads/Compressed/MotionBox-1.6.0/MotionBox: error while loading shared libraries: cannot open shared object file: No such file or directory

How do I install the dependencies?

That’s interesting I didn’t know MotionBox would run in Wine.

1 Like

Well currently you are supposed to install VLC first: sudo apt-get install vlc

Thank you @GPL, that’s actually a mistake on my side, next release will have proper permissions.

When I made the Arch PKGBUILD file (which needed to generate Arch installer packages) I ran into this problem and I immediately added the chmod lines to the install script, but in progress I forgot to report it to you, so it’s my fault.

But at least it is not an issue on Arch. :smile:

@idotman You don’t need sudo to run MotionBox, just type ./ and Wine also not needed.

I’m working on the next revision that will have the proper permissions, VLC and included.

I successfully made it run with just the ffmpeg dependency this afternoon \o/ !

I already have that package! It comes preinstalled on Kubuntu! Please check the screenshot. Why am I unable to run!

I tried without sudo too. Still unable to launch!

Could you try this build artifact:

You only need to chmod +x MotionBox and then you should be good to go. Still doesn’t work…

How do I build that? I have no idea. :frowning:

Well it’s just the download page for generated artifacts.

But that doesn’t matter because I pushed MotionBox 1.6.0-2 yesterday so you can get the latest archive from here:

1 Like

@GPL, @idotman, I’m looking for someone to maintain an Ubuntu repository for MB if you are motivated or know someone :wink:

@bunjee I am not using Ubuntu actively, but I will think about the possibility to maintain a Launchpad repo for it. :smile:

1.6.0-2… But the download page still downloads 1.6.0! Could you please build an appimage? That would be truly a blessing!

Hello, folks!
I was looking for reliable youtube client and I think I found it :smile:
But there is little interception while trying to build… The script ./ linux says:

cp: cannot stat ‘/usr/lib/x86_64-linux-gnu/’: No such file or directory
$ sudo apt-file search
libqtwebkit4: /usr/lib/x86_64-linux-gnu/
libqtwebkit4: /usr/lib/x86_64-linux-gnu/
libqtwebkit4: /usr/lib/x86_64-linux-gnu/
$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 19.10
Release: 19.10
Codename: eoan

So, I tried to reinstall with Synaptic. Didn’t help.