Unable to start MotionBox 1.4.0 on LinuxMint 18.03

Hi there,

I was using MotionBox 64 bit on my LinuxMint 18.03 (based on Ubuntu 16.04) without any problems. Now I have upgraded to 1.4.0 and I get this error message at the startup:

./MotionBox: error while loading shared libraries: libpng16.so.16: cannot open shared object file: No such file or directory

Needless to say that libpng16.so.16 is in the directory.

If the issue cannot be solved, where can I download back the 1.3.0 version?



Greetings Marco,

Could you try copying libpng16.so.16 to the MotionBox root folder and see what happens ?

Hello bunjee,

because a photo is worth more than 1000 words, that’s my Motionbox “configuration”: all files in /opt/motionbox, including libpng16.so.16. The permission of the MotionBox file is 775 while the permission of all the other libraries (including libpng16.so.16) is 644, apart from the libSk* libraries, which is 775.

See image

This was also the previous “configuration” weith version 1.3.

Thanks for your help :smile:

Yeah, that should actually work.

This is probably related to the recent move to Qt 5 and rpath behavior. I’m not sure how to fix this without testing on LinuxMint directly.

Here is a link to MotionBox-1.3.0-linux64: https://uploadfiles.io/iwqwa


I’ll keep using 1.3 for now.
I’ll keep an eye to this thread and github to see if you come up with fixes in the meanwhile.
Thanks again!

Bad news,

now even 1.3.0 gives the same error. Between 1.3 and 1.4 I tried to build MotionBox from sources (I gave up as I didn’t want into a few GB of Qt5 files) and must have downloaded some Qt4-5 files that have change my configurations so now neither versions work.


Oh wow, maybe it’s not related to Qt 5 after all.

The solution would be for me to install LinuxMint and test on my side. Ultimately I would like a generic archive that works everywhere. Unfortunately I have no time to dive into this at the moment.

Fair enough.
I tried to install libpng for ubuntu, and it spit out another lib-related error.
As you said, MotionBox is not architecture-independent, hence it will work for Arch/Fedora-based architectures, but may not for Ubuntu/Debian’s.
Keep up the good work :smile:

After having ironed out all the lib errors, I got stumped with this one:

    This application failed to start because it could not find or load the Qt platform plugin "xcb"
in "". Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.

My Mint does have xcb, though:

ls /usr/lib/x86_64-linux-gnu/qt5/plugins/platforms
libqeglfs.so    libqminimalegl.so  libqoffscreen.so
libqlinuxfb.so  libqminimal.so     libqxcb.so

Thatr’s where I had to stop. Can’t get any further.

Just tested on linuxmint-19-cinnamon-64bit-v2 and it works.

I’m now trying to fix linuxmint-18-cinnamon-64bit.

Okay, I’ve been working on this for a few hours. The following archive should run on linuxmint-18-cinnamon-64bit: http://dl.free.fr/qVfcUqsVr.

@soliton, could you give it a spin on your side ? You have to run it using the start.sh script.


just installed and works like charm (well, at least that’s my test of the first 3 minutes).
It actually loads a lot faster.
What was the issue?

Glad to hear that,

A few missing libraries and had to enforce LD_LIBRARY_PATH to the application folder.
Linux archives have been updated: http://omega.gg/MotionBox/get.

Could you confirm that Youtube playback works, and your VLC version ?


I have installed VLC 2.2.7 from PPA repository and 3.0.3 from snap.
When I start MotionBox, which version will the application pick up?
Youtube does work, however videos take ages to start up, in the range of 1-3 minutes.
Do you notice the same problem?

If Youtube videos are starting I suspect it’s using 3.0.x.

Youtube videos take a long time to load due to the current VLC input-slave implementation: https://trac.videolan.org/vlc/ticket/19689. However 1-3 minutes range seems like a long time.

I am not so sure. Even before installing VLC 3.0 , MotionBox was actually working with 2.2.7
is there a MotionBox log file where I can check which version it is picking up?
Is there a command-line parameter to force the VLC path into MotionBox?
(/usr/bin/vlc for 2.2.7 and /snap/bin/vlc for 3.0)

Maybe you can try to edit the start.sh and append /snap/bin/vlc to the LD_LIBRARY_PATH.

Maybe you can try to edit the start.sh and append /snap/bin/vlc to the LD_LIBRARY_PATH

Great. I’ll see what happens.