MotionBox stopped working

Hello Bunjee,

Damn, I don’t know what happened?? Last night before bed MotionBox was working like a charm and this morning it has stopped. Maybe an update killed it?? It opens just fine, it updates the feeds just fine but when I click on the play button the spinner pops up for a second or two then just goes away. Bummer!!! I tried audio only, video only reboot, restart MotionBox, reinstall MotionBox nothing helps. Any ideas Bunjee?? Maybe I can delete a config file or something?? Where is the config file in Ubuntu 18.04 located?? I looked in hidden home folders, /usr/share I can’t seem to find it, not that that would help?? Oh, I am using a repackaged deb file of MotionBox 1.5 that I found on the internet if that matters. I really don’t want to build anything if I can avoid it :slight_smile:

Please help Bunjee :slight_smile: :slight_smile: :smile:



Hi @Singtoh, Yes I can reproduce on my side, I’ll investigate on this.

The user data folder is here: /home/[USER]/.local/share/MotionBox

Today was the first time I installed MotionBox [version 1.5.0-1.2 on Tumbleweed] and I encountered the same error.

MotionBox is requesting YouTube videos using HTTP instead of HTTPS and YouTube is responding HTTP is not supported.

As a workaround on my machine until MotionBox is patched to use HTTPS, I’ve installed the utility mitmproxy and configured MotionBox to use it as a proxy at localhost on port 8080. I run the command mitmproxy --scripts

Contents of the script:

Redirects YouTube HTTP requests to HTTPS
from mitmproxy import http

def request(flow: http.HTTPFlow) -> None:
    if flow.request.pretty_host == "":
        flow.request.scheme = "https"
        flow.request.port = 443

Yeah that’s actually related to Youtube no longer supporting http requests on get_video_info calls.

I’ve actually fixed it on Git and plan on releasing a new version soon:

Nice workaround @Roscoe.

Ok, wow, you guys are on it!! Super!! Thanks Roscoe, I’ll give your work around a go.

Bunjee, I was wondering if there is an “Official, Kinda, Sorta” MotionBox deb file that I can download when this is fixed up?? The deb file I have now is motionbox_1.5.0_repack0_amd64.deb. I can’t seem to find the website I downloaded it from now, but even so if there is updates or some such would I receive them using that deb package?? Just wondering if I will get the updates when you get it fixed up, or will I have to download a new deb file for MotionBox?? MotionBox deb files seem to be more rare than “Dinosaur Shit” as far as I can tell just searching around a bit on the internet??

Anyway, you guys are super!! Thanks a bunch for fixing this up, hopefully soon :smile:



Not currently, the only thing I’m maintaining is a Ubuntu 64 bit archive on the download page. I don’t know who did the debian file you downloaded :stuck_out_tongue:.

When MotionBox is updated you’ll get a notification inside the app.

Ok, Cheers! I’ll just download the updated tarball and run it from there I guess. Thanks a bunch :smile:

The updated version is available, get it here:

It should fix Youtube playback without any workaround.

Thanks a bunch Bunjee!! I kept the old .deb file installed and copied the extracted fixed MotionBox-1.5.0-linux64.tar.gz, after renaming it to “montionbox”(minus quotes) to /opt/motionbox and all is working like a charm. Cheers Man!!!