Jumping between positions in videos are not working anymore in 1.3.0

In the last few weeks I found a new problem. If I try to jump to any position in any video, MotionBox restarts the video but the last shown frame freeze on the screen and only the audio restarts. If I stop the video and start it again from the beginning it is working as intended. Is there any way to fix this behaviour?

Thanks for your answers!

Greetings GPL,

Yes, this is related to VLC 3.x.x: https://trac.videolan.org/vlc/ticket/19689.

MotionBox is supposed to play the video stream together with the audio. Until they fix it I’m afraid seeking is going to be broken on Youtube.

Thanks for your feedback !


thank you for your answer! Then I will wait for the VLC fix (I hope they will be fast).

Actually, I have found a workaround and it should be in the next release.

MotionBox 1.4.0 is live and it should fix your seeking issue.

Thank you for the next release!
I tried the 1.4.0, but I ran into some trouble. I am currently riding Arch Linux which has the most recent icu package (version 61), while MotionBox try to find the libraries from the icu 60 package.

$ ./MotionBox
./MotionBox: error while loading shared libraries: libicui18n.so.60: cannot open shared object file: No such file or directory

I downloaded manually the icu 60 libs and tried to use them with the LD_LIBRARY_PATH and also I tried to copy them to the /usr/lib. In both case I suppose MotionBox found the libs, but I got the following message:

This application failed to start because it could not find or load the Qt platform plugin “xcb”
in “”.

Reinstalling the application may fix this problem.

But xcb installed and the most recent, so it can’t be the problem.

Do you have any idea how can I fix this issue?

Greetings @GPL,

I guess I need to package libicui18n.so.60 in the archive.

As for the “xcb” error, can you confirm XCB is installed on your distribution ?

Could you try extracting the following archive in the folder of the application: http://dl.free.fr/gLKLvLZBf


if I extract the content of the archive, I got a new extra line:

This application failed to start because it could not find or load the Qt platform plugin “xcb”
in “”.

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, xcb.

Reinstalling the application may fix this problem.

Also I have the following installed packages related to XCB:
xcb-proto, xcb-util, xcb-util-image, xcb-util-keysyms, xcb-util-renderutil, xcb-util-wm, lib32-libxcb, libxcb

Alright, this might be due to the Qt 5 port. I’m going to check on a clean Ubuntu tomorrow.

Tested on a clean Ubuntu 18.04 this morning (along with apt-get install vlc).

It seems to work properly, so your issue is probably related to Arch Linux.

Thanks for the investigation.

I will try to find out what can be the problem in my case.

@GPL, You should try the latest Linux archive and run MotionBox with start.sh.


Thank you, it’s working like a charm! You are the best! :slight_smile:

I see that you set the LD_LIBRARY and QT_PLUGIN path to the MotionBox folder in the start.sh and you added 2 libqxcb files - maybe these libs are the keys to the problem. :slight_smile:

(Some fun facts:
Last week I tried to compile both the MotionBox and the Sky kit - both failed with dependency and other problems.
I also wrote a start.sh file for myself for the 1.4.0, but I always stuck at the xcb loading error.
So I still used - until now - the 1.3.0 with the YouTube seeking problem.)

Thanks for your feedback, glad to hear that you got it running on your side. The Linux version is still early in development not to mention MotionBox is still in alpha, but we are making progress !

These two xcb libraries were tough ones to debunk. That post actually gave me the key: https://forum.qt.io/post/339958.

The Qt sometimes - at least for me - a mystery… Anyway it’s working now!

One thing I forgot to mention: when I opened the 1.4.0, it was completely empty. I figured out, that it’s using different path to save the data than the previous versions. I don’t know if it’s intentional or not.
1.3.0 and before: ~/.local/share/data/MotionBox/
1.4.0: ~/.local/share/MotionBox/

If I copy the data into the new location, everything is fine.

Oh, I was not aware of this, it’s probably related to the transition from Qt4 to Qt5.
Since your playlists are stored in XML, it shouldn’t be a problem moving the folder to the new location.

Also, it wouldn’t hurt backuping them manually if you really care about them, because they are stored locally.

It wasn’t a problem anyway, because I could move the files easily and I’m already have a backup with FreeFileSync (I just have to modify the input directory for the backup process). :slight_smile: